needrestart 0.5

needrestart checks which daemons need to be restarted after library upgrades. It is inspired by checkrestart from the debian-goodies package. It does not rely on lsof as checkrestart does.

Supported package manager backends (for init script retrieval):

  • dpkg
  • rpm
  • pacman

Changes in 0.5

  • Ignore mapped files in /tmp.
  • Handle LSB tags case insensitivly. (Debian Bug#731165 by Christian Ionescu-Idbohrn <cristian.ionescu-idbohrn@axis.com>)
  • Prevent config file in dpkg.cfg.d to break dpkg after removing needrestart. (Debian Bug#732461 by Andreas Beckmann <anbe@debian.org>)

See also


Comments !