PostgreSQL - Forgotten database cluster upgrade…

After upgrading a system running Debian GNU/Linux from release Squeeze to Wheezy I almost lost my PostgreSQL database. The following PostgreSQL versions are shipped with recent Debian releases:

Debian Release PostgreSQL Version
Lenny 8.3
Squeeze 8.4
Wheezy 9.1

After upgrading from Lenny to Squeezy I missed …

more ...